Новости Easyhotspot — июль 2017

С момента прошлой публикации «много воды утекло»! И так как новостных сообщений не было давно, могло создаться впечатление, что «бобик сдох» (развитие программы прекращено). На самом деле в программе произошли глобальные и важные изменения, которые просто отняли много времени! Итак, вот список изменений, произошедших в программе:

  • Веб-интерфейс Easyhotspot перенесен с фреймворка Codeigniter версии 1.5.4 на версию 3.1.2
  • В веб-интерфейс биллинга Easyhotspot внесен ряд изменений, дополнений и улучшений;
  • Обновлена страница авторизации
  • Обновлен модуль СМС-авторизации
  • Обновления платежных модулей
  • В скрипт-инсталятор внесен ряд изменений
  • Изменения и исправления в прочих скриптах
  • Изменения в документации

Веб-интерфейс Easyhotspot перенесен с фреймворка Codeigniter версии 1.5.4 на версию 3.1.2

Фактически, выпущенный «давным-давно» Codeigniter версии 1.5.4 с каждой новой версией PHP требовал все большего количества «костылей», замен «устаревших» и отмененных функций, подавления каких-то «предупреждений», «извещений» и т.п. «Масло в огонь подливал» еще и сервер баз данных MySQL, который тоже (с версии 5.7.х) начал более строго относится к формируемым запросам в базу. Поэтому, в первую очередь данное обновление является своеобразным «заделом на будущее», т.к. решает проблему работы биллинга под управлением последних версий PHP, MySQL и т.д., которые уже вовсю используются в новых версиях дистрибутивов Linux. Предполагаю, что в дальнейшем «ареал» использования новых версий данного ПО будет только расширяться. Поэтому, фреймворк и был заменен новой версией. Использование новой версии фреймворка повлекло за собой использование и новой системы авторизации в биллинг (входа в саму «черную админку» EasyHotspot). Был выбран скрипт Ion Auth, который в свою очередь, наложил «ограничение снизу» на версию PHP, используемую сервером биллинга. Теперь версия PHP на сервере биллинга должна быть не ниже 5.3.1.

Читать далее «Новости Easyhotspot — июль 2017»